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An OrCAD Tutorial

1. Introduction

OrCAD is a suite of tools from Cadence for the design and layout of printed circuit boards (PCBs). We
are currently using version 9.2 of the OrCAD suite. This document will give you a crash course in
designing an entire circuit board from start to finish. This will be a very small and simple circuit, but it
will demonstrate the major concepts and introduce the tools behind completing a PCB design. After
you have completed this tutorial, you will know all the steps needed to make PCBs using OrCAD. This
is not, however, a guide to the inner workings of the OrCAD interface. You should use this document
in conjunction with the online OrCAD help and tutorials.

The circuit you will design is shown in the figure below. The main component is a programmable logic
device (PLD) from Xilinx. PLDs, as the name implies, are programmable devices that can be used for
a variety of useful tasks, and it is useful to be familiar with using them. In this circuit, we will use the
PLD to light up a 7-segment LED display that will be used as a counter. Also in the circuit: a power
connector for a 9-volt battery, a header for general purpose 10, a pushbutton switch, a programming
interface for the PLD, and some miscellaneous resistors and capacitors.
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OrCAD really consists of two tools. Capture is used for design entry in schematic form. You will
probably be already familiar with looking at circuits in this form from working with other tools at Rice.
Layout is a tool for designing the physical layout of components and circuits on a PCB. During the
design process, you will move back and forth between these two tools.

Save your work frequently while working on this tutorial. You will not be reminded to do so.

2. Before You Begin

It is helpful to be very organized when you are designing. OrCAD will create many files and if you
keep all of them in the same directory, it can quickly become very confusing. I like to make a directory
hierarchy and put associated files into subdirectories. Before beginning, navigate to the directory in
which you will keep your project and create the following subdirectories:

= sch —for your schematics.
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| i b —for symbol and footprint libraries.
= boar d —for your board files.

= comps — for component datasheets.

= assy —for assembly related documents.

For larger designs, more subdirectories would be desirable, but these will be sufficient for this project.

3. Starting a New Schematic Project

To create a new project, first start OrCAD Capture and click File>New->Project. You will see the
following dialog box.

X
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Browse to the sch directory that you created and name the project Elec424Tutorial. You now have an
empty project workspace. You should see an empty schematic page and a project window like the
following.
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4. Creating a Schematic Parts Library
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OrCAD allows you to create a library of part symbols for use in
schematic entry. These libraries are kept in separate files that are
included in the project workspace. This allows you to reuse libraries in
other designs. We will know create symbols for all the parts in our
design.

IMPORTANT NOTE: When you place a part in a design, OrCAD creates a
cached copy of the part symbol in the design file. This makes schematic
projects portable but can also introduce some problems later in the design
cycle. Please resist the temptation to edit parts directly in schematics, as this
will make the design out of sync with respect to your library. Always edit
symbols in the library and then use the Replace Cache and Update Cache
commands to change the part in schematics. See the OrCAD help for more
information on these commands.

First we must add a new library to our design. To do this, click
File>New=>Library. Your project window will now look like the figure
on the left.

Right-click the library file and select Save As.. Name the file

Elec424Tutorial and place it in the |i b directory that you created
earlier. You are now ready to add parts to your library.
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5. Creating Schematic Symbols

To add a new part to your library, right-click the library file and select New Part. This will bring up a
dialog box for New Part Properties, which looks like this.

New Part Properties il
Mame: #C9536-FLCCA4 Ok I
Fart Beference Prefix: IU s |
PCE Footprint; I Part Alisses... |
I Create Convert View Attach Implementation. .. |

Multiple-Part Package
Parts per Pka: I'I Help |
Package Type Fart Mumbering
* Homogeneous ' flphabetic
" Heterogeneous € Wumeric v Pin Humber Visible

CADOCUMENTS AND

We will be making a symbol for the Xilinx XC9536 PLD. This part comes in a 44-pin PLCC package.
Name the part XC9536-PLCC44. Leave the Part Reference Prefix as U*. You can leave the default values
for all the other settings. Click OK to bring up the workspace for part creation. It should look like the
picture below. Tools for working with the part are located on the toolbar on the right-hand side of the
screen.
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F
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! part Reference Prefixes (also known as Reference Designators) help categorize parts in your schematics and PCB layouts.
There is a pseudo-standard reference for most types of parts. For example, C is used for capacitors, R for resistors, L for
inductors, U for ICs, and X for crystals.
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To get started, drag the dashed line on the workspace to make it alittle larger. Y ou won"t be able to fit

O

Shape:

i x|
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Tupe:

A
Cancel |

I Passive

j User Properties. .. |

too many pins on the part with its current size. When it is large enough, use the Place
Rectangle tool to draw a solid outline in the same place as the dashed line. Use the Place
Pin tool to place pins on the part. You will see a dialog that looks like this.

Width
& Scalar
" Bus

Help |

I¥| Pirr jsible

Refer to the part datasheet for the correct pin numbers for the PC44 package. You can either download
the datasheet from the Xilinx web site (www.xilinx.com) or from OwInet at the following location.

/ hore/ j pfrant z/ el ec424/tutori al / conps/ XC9536. pdf

The default pin Shape (Line) and Type (Passive) are OK for most pin types. For clocks and active low
signals you may want to use some of the other shapes. You will also want to use the type Power for

power pins. When you do this, make sure that the Pin Visible
check box is checked. Also, | usually like to place my power
pins near the top of the part and ground pins near the bottom. As
a last touch, double-click the text that reads <value> and change
it to read XC9536-PLCC44. When you are all done, your part
should look something like the symbol on the left.

Save your part and close the window. You may get a warning
about duplicate pin names, but that is OK to ignore. Your part
will now be visible in your library.

Some parts are already in existing OrCAD libraries. It is usually
OK to copy these parts for use in your own design. For example,
let"s say we want to use a ssmple resistor in our design. First, we
need to open the library that contains the resistor. To do this,
select File>Open->Library. OrCAD keeps all of its libraries in
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Select the library called Discrete. This will open up a new
window showing the contents of the library. Find the part called

R and highlight it. This is our resistor. Select Edit>Copy from the menu and then highlight your own
library. Select Edit->Paste from the menu and this will paste the part into your library.
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When you do this, some extra parts will show up in your library. These are part aliases (the same part
but with a different name). Y ou can tell the aliases by the -, that isinside the little gate next to the part
name. Y ou don“t need the aliases they will just cause confusion. Delete them from your library.

I have provided a library of the remaining parts for use in this design. Open this library file and copy
the all the parts into your library. You can find this library on Owlnet at:

/ hone/ jpfrantz/ el ec424/tutorial/lib/tutorial.lib

IMPORTANT NOTE: There are a few things to note about copying parts from existing libraries. First,
always be sure to check the part you are copying against a datasheet for correct pinout, number of pins,
etc. Second, some of the standard parts will have power pins that are invisible. Personally, | feel that this
is a very bad design practice that can lead to errors in your design. If you copy a part that has invisible
power pins, please be sure to make them visible. Trust me, this can save you a lot of pain and trouble
later. Finally, beware of so-called “heterogeneous’ parts. These parts split across multiple symbols. For
example, you might see a part with general pins on one symbol and power pins on another. In general,
heterogeneous parts should be avoided because they can cause problems. However, they may be
acceptable for very large parts such as processors.

6. Schematic Entry

6.1 SETTING UP THE ENVIRONMENT - Now that you have your parts library set up, you are ready to
begin entering schematics. You can see from the project window that you already have one page of
schematics called PAGEL in a folder called SCHEMATICL. If you can't see this, click on the ,+" next to
the dsn file to expand the view. Even though our circuit is small enough to fit on one page, we will use
two pages to demonstrate a schematic with multiple pages. First add a new schematic page by right-
clicking the schematic root folder and selecting New Page. You will be prompted to provide a name for
this page. Call it Page 1 — Power & Connectors. Now rename the original page by right-clicking and
selecting Rename. Call this Page 2 — Xilinx PLD. It is always nice to give your schematic pages useful
names. While you are at it, rename the schematic folder in the same manner, calling it Elec424Tutorial.

Open page 1 of your schematics by double-clicking it in the project window. This will bring up a blank
page. Before we place parts, let"s do a couple of things. First, | like to make the page size a bit bigger
than the default. You can fit a lot more onto the page and it will still look nice when printed. To do this
select Options>Schematic Page Properties... Click the Custom radio button and use the following
values (width=15.2, height=11.5). Second, there is a title block in the lower right corner. We are going
to replace this with our own, so highlight the title block and delete it. We add a new title block by
selecting Place->Title Block... You will see the following dialog box.

Place Title Block | Place Title Block i : |
e e
| |RiceTitleBlock
Cancel | Cancel |
TitleBlockO -
TitleBlockOM Add Libram... Add Libram... |
TitleBlock 1N Remove Library Remove Library
TitleBlock2 LI
Help | Help |
Libraries: Libraries:

. CAPSYM
[esign Cache Mame: [eszign Cache Mame:
I IHiceTitIeBIock
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The title block is in your library, so we need to add that to the list of libraries. Click the Add Library
button to browse to and select the library you created for the tutorial. Once you have added the library,
you will be able to choose the RiceTitleBlock to add it to your design. Place the title block in the lower
right corner of your schematic page. The title block has fields to put information for each page of
schematics. Double-click the text to edit each field and change the information on each page so that it
looks something like this.

Rice Uniwersity

Title R]Q:JI___
Power & Connectors 5
Document Number Fev
Bec 424 - Group ¥ - Drawn by Patrick Frantz wl
Dotz Sunday, Decermber 23, 2001 Eheet 1 of 3 ==
| ¥ 4
Rize University S -
Trthe R_]L:_al___
Hline PLD =
Document Mumber Rew
Hec 424 - Group ¥ - Orawn by Patrick Frantz xl
Date: Sunday, December 23 2001 Eheet 2 of 2

6.2 PLACING PARTS & MAKING CONNECTIONS - You are now ready to start placing the electrical

components for your design. Open the first page of your schematics and click the Place Part
| icon on the toolbar on the right side of the screen. You will then get a dialog for choosing
which part you want to place on your schematics.

x|
COMM JACK PR
Cancel |
Part List:
CAP MNP - Add Library... |
CaP POL
COMZ Bemowve Library |
COMz20
NN JACE P Part Search... |
LED
AeE03/4
PUSHBUTTOMN
R |
T 3 ll Help
Libraries: — Graphic
|Desi§n Cache * Marmal J?
) Convert 2
. VRS
— Packaging 1
Partz per Pkg, 1
Pt I - I <Waluer
Type: Homogeneous

Select the part CONN JACK PWR and click OK. Place the part on the left side of your schematic page.
Now place the remaining parts on both pages using the attached completed schematics as a guide. A
PDF file of the schematics can also be found on Owlnet.

/ homre/ j pfrant z/ el ec424/tutorial/sch/ El ec424Tut ori al . pdf
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A small hint for moving around in OrCAD: use I’ and ,,0" to zoom in and out, respectively. ,,C* will
center the design at your cursor. ,R" will rotate a part. Y ou can do these actions while in the middle of
another action (e.g. while placing a part). You will also notice that each part has a value associated
with it. You can change this by double-clicking the current value. In this manner you can give all your
capacitors, resistors, etc. the appropriate values. When you are done, the first page of your schematics
should look something like this.

= + | 3 | H | 1

=

HiL 1
I_n
e

nnnnnn iy

— RICE

=
il Su— I
e

L -L | ,1 Now we need to draw nets to make electrical connections between components.

To do this, click the Place Wire icon and connect the components as shown in
the attached schematics. Use the Place Bus and Place Bus Entry icons to place busses and bus
connections (you don“t need to do this in these schematics). When you are done, the first page of your
schematics should look like this.
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Now you need to add power and ground connections to some of the parts. OrCAD has several built-in
symbols for power and ground. | like to use a symbol that explicitly names the nets, as shown in the
picture below. I do this because many designs will have multiple power and ground nets. Explicitly
naming them helps prevent shorts and other errors. It also makes your schematics easier to read. Add
power and ground to your schematics now.

VCCH

I

GND

6.3 CONNECTING PAGES AND NAMING NETS - Since some of these connections go to the PLD, we need

to a way to connect the two schematic pages together. We can do this by using off-page connectors. To

place these click the Place Off-Page Connector icon. Then select the connector called OFFPAGELEFT-L

Or OFFPAGELEFT-R, it doesn"t really matter which one, they are functionaly the same. You can

<L | place this on your schematic just like a part and then connect to it with a net. Off-page

connectors are linked by a common name. For example, two off-page connectors on separate

pages with the name CLK will be considered by OrCAD to be one net. To name a connector, just

double click it to get a naming dialog box. Name your connectors now using the attached completed
schematics as a guide.
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IMPORTANT NOTE: For reasons that will become clear later, | like to place my off page connectors as
close to the edge of the page (right or left) as possible. This makes clear which nets go off page and
which don"t. It will also help you find mistakes on naming nets across pages.

Normal nets can also be named. This is extremely useful and can help tremendously in the layout
process. | encourage you to use the Place Net Alias icon to name any important nets such as clocks,
address and data bus lines, and other specific signals you are interested in. To name a net, first
— | highlight the net you want to name and then click the icon, you will be given a dialog box to
enter the name of the net. You can position the text anywhere you like. If you have already
attached an off-page connector to a net, then that net already has the same name as the connector. You
don"t need to give the net an alias unless it will make your schematics more readable.

H-"{ | If you have any pins on parts that are left unconnected, use the Place No Connect icon to mark
it in your schematics.

Now complete your schematics as shown in the attached reference.

7. Preparing for Layout

7.1 ANNOTATION — Now that your schematics are complete, you are ready to prepare to export the
design to Layout. From now on, you will be working in both Capture and Layout. The first step in
preparing your design is to annotate it. Annotation really involves several steps. First, we will assign
unique reference designators to all of the parts in our circuit. Remember reference designators? These
are just labels that are used in Layout to uniquely identify different types of parts. If you look at the
hierarchy view in the project window, you will see a jumble of reference designators. You might have
several capacitors named C1 or a lot of parts that have the label, R?, C?, U?, etc.

1] EIec424Tutorial.opi i (] 1 il Elec424Tutorial.opj o m]

Hierarchy View Before Annotation

o) ctgooomy (40l e IBl C1(1000F)
B 1 (ouR) [0 C2 (10UF)
B oaqoe e B c31our)
B 1 (z.20R) ~odg) 4 {0.AUF)
Bzt @40 e B <5 (0.10F)
O C2inuR) 0] CE(D.1UF)
B czows N e B <7 (0.10F)
0 czinauR B cainaum
...... B czn1ur D) ConiuR)
Bl c2iup --fp) C100(0.10F)
B ez 0 B <11 (0.10F)
...... B 2 (0.1 B C1zi2.20F)

B b1 {BLEY .13l D1 (BLUE)

B 1 rrooze) B 71 (P3-00ZA)
...... B 12 (comm-zz1m) B 12 (comn-zxin)
D) 13 (CONN-223) --[D} 33 (CONN-243)
B R1{150) -0 R1(1E)

...... Bl Rri{1K) -[Bl Rz (150

B 51 (PUSHELTTON) B =w (PUSHELTTON)
Bl U1 (MaRE0E4) U1 (MARED34)
B vz (TILs1 D} Uz {TILELL

I U3 (HCes3e-PLCC4) ~[D] U3 (XC9536-PLCCA4)

Hierarchy View After Annotation
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To fix this, we will use a few of the annotation tools. In the file view of the project explorer, highlight
the top-level design file (the one with the dsn extension) and then select Tools=>Annotate. You will see
the Annotate dialog box.

Annotate

x|
ok |

Cancel |

—&ction Hel |
' |ncremental reference update oen

" Unconditional reference update
" Feset part references to "7

" Add Intersheet References

" Delete Intersheet References

—Mode

" Update Occurences

' |lpdate Instances [Prefered)

 Phwsical Packaging —
LCombined property string:

I {WalueHS ource Package}

[~ Beset reference numbers to begin at 1 in each page

[~ Do ot chahge the page humber

In a new design, it is best to first reset all the part designators. To do this, click the radio button that
says Reset Part References to “?” and then click OK. You will be asked if you want to save your design
before proceeding. Every part in your design will now have a question mark in its reference designator
instead of a number. Now, reopen the annotate dialog box and check the box that says Incremental
Reference Update and click OK. This will go through your entire design and number each part starting
with 1 for each part type. If you now look in the hierarchy view, you will see that you have a nicely
ordered list of parts.

7.2 INTERSHEET REFERENCES — The next thing we will do is add intersheet references to your
schematics. Doing this will place page numbers near each off-page connector that indicate to which
other pages that net is connected. This is invaluable during design and debug because it will help you
track individual nets across a large design in many pages of schematics. Since we only have two pages
of schematics in this design, we could probably get away without adding intersheet references;
however, it is a useful tool and should always be used for good design practice. Another reason for
using this tool is that it helps to find mistakes in naming nets. For example, say you have a net named
CLKIN but on one page of schematics you mislabel this net CLKIM. After annotation, these two off
page connectors will not have page numbers next to them, indicating that they are single-pin nets. This
would be an immediate warning flag that something is seriously wrong with your schematics. To add
intersheet references, bring up the annotate dialog box again. Select the radio button that is labeled Add
Intersheet References. You will get a secondary dialog box, and you can leave the default values as
they are for now. Just click OK to continue. As far as schematics are concerned, your design is now
fairly complete.
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7.3 CREATING FOOTPRINT LIBRARIES — We are now ready to begin working in layout to proceed with
our design. The first thing we need to do is create a library of footprints to be used in our PCB layout.
Footprints® are a representation of the physical area that a part occupies on a PCB.

IMPORTANT NOTE: | cannot overemphasize this point. IT IS ABSOLUTELY CRUCIAL THAT
YOUR FOOTPRINTS ARE CORRECT. Double-check them, triple-check them. It is sometimes
possible to live with an error in a schematic symbol, but a footprint error can often sink your entire
design. Please be VERY CAREFUL.

Start Layout Engineer"s Edition® to begin working with footprints. Libraries for Footprints are very
similar to libraries for schematic parts. Layout has a separate tool for working with footprint libraries,
though. To start this tool, select Tools=>Library Manager. You will get a new window that looks like
this.

=181 x|

File Edit “iew Tool Options Auto Window Help

SlE x|#|E| 82|2lo] ol O BT o] afufs 24 a2 ]2
% |-950 [v [300 |G 50 Lme . -
- x| rary - Pin Tool {DRC OFF) =[]
(il
.---Lihraries
| [BCONTOOT <] | | -
| |BCON15ET |
| |BGA
|{cLee |
| (DCONOSO0T ML
Add... I Remove I
Footprints -
| Create New Footprint... I: o
| Save I Sawve As... I S o
| | Delete Footprint I _ - [~
- 21

; [950,300] RAM: 3014K Used, 1409101K Available

You will notice that there are already several libraries available for use. OrCAD has many existing
footprints that you can use in your own design. As with the schematic symbols, be very careful to
check that these footprints for correctness before using them. Often, you will have to make footprints
for parts that don"t already have one. Most datasheets for parts will contain the mechanical information
necessary to make a correct footprint. However, before making a footprint it is necessary to understand
a little bit about how PCBs are constructed.

2 Footprints are also sometimes referred to as shapes or land patterns.
® There are two versions of Layout: Engineer"s Edition and Plus. They are identical with the exception that Plus has an
autorouter. We will not use this feature.
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PCBs consist of a number of electrical and non-electrical layers. 2 to 4 electrical layers are fairly
common for simple circuit boards. 8 to 20 layers can often be seen in many industry applications. The
diagram below shows the electrical layer stackup for a 4-layer board like the one you are making now.
The top and bottom layers are used for routing nets between parts, while the inner two layers are solid
copper planes for connections to power and ground. A fiberglass or epoxy resin dielectric material
separates each of the layers.

4-Layer Board Stackup

Layer 1 - Horizontal routing.
loz. copper. 0.005" trace
B S width with 0.005" spacing.

0.0040

0.0014—— Layer 2 - Ground Pane. 1oz.

copper.

0.0628in. 0.0520

Layer 3 - Power plane. 1oz.
copper.

0.001477A
0.0040
A J

Layer 4 - Vertical routing.
loz. copper. 0.005" trace
width with 0.005" spacing.

There are also several non-electrical layers:

Drill Layer — This layer defines finished drill sizes and drill locations for parts that have pins
that go through the board. It is also used for general documentation.

Solder Mask — There is a coating on the top and bottom of the PCB that prevents solder from
flowing freely on the board. This is what gives most circuit boards their green color.

Solder Paste — For parts that are ,,surface mount” (the pins rest on the surface of the board and
do not go through it) this layer defines the spaces where solder (in a paste form) will be applied
for circuit assembly. This layer is not used for manufacturing and is only used by the person
assembling the board.

Silkscreen — This layer is used for documentation of a PCB. Reference designators and other
useful text can be printed on the top or bottom of a PCB using a process similar to that used for
silkscreen t-shirts.

Footprints are composed of one or more padstacks. These padstacks define how a pin on a part looks
on each of the electrical and non-electrical layers. Each of your footprints will need at least one
padstack defined. Let"s take alook at a padstack definition for an existing part. In the Library Manager,
select the library DIP100T and highlight the first part DIP.100/14/W.300/L.700. You will see the part
footprint in the Library Manager.
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& Layout Engineer's Edition -- {unnamed)
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I8 DiP.1 0071 473004700 D ———— :
| |DIP.100/1 47.300/L.725

| |DIP.10071 4. 30041750 I & C

| |DIP.1 0071 49300775 _ om p
| |DIP.10071 473007800

ERewers A || 0 DIP.100/14/W.300/L{700
RSV &VALUE

| [DIP.100{16/%.300/L.825

| |DIP.100/16/%.300/L.875

| |DIP.100{16/%.300/L.900

| |DIP.1004168%/.300/L.950

| |DIP.100/187%.300/L.900

| |DIP.100/18/\.300{L.925

| |DIP.10041804/.300/L..950 |
| |DIP.100/207¥/.300/L.975 =l

| | Create New Footprint... I

| Save I Save As... I

| Delete Footprint I

EDIPJ 0014/4.300/L.700 [100,-100] RAM: 324K Used, 1371168K Available

Layout uses a series of spreadsheets to store information about your design. Padstacks are stored in the
@ padstack spreadsheet. To access this spreadsheet, click the View Spreadsheet icon and choose

Padstacks. This footprint is composed of two padstacks, one for pin 1, which is square, and
another padstack for the other pins. When you open the spreadsheet, you will first see a padstack called
T1. Padstacks T1 to T7 are default padstacks and can be modified for your own use. The padstacks we
want to look at are at the bottom of the list; scroll down until you see DIP100T.llb_padl or
DIP100T.llb_pad2. These are the two padstacks for this footprint. You will notice that there are numbers
on some of the layers that define how the padstack looks physically on that particular layer. We will
come back to this in a minute.

Close the padstack spreadsheet and open up the footprints spreadsheet. The name is confusing; it
should really be called something like the pins spreadsheet because this spreadsheet defines the
locations of the pins and also which padstack they use. You will see each pin for the part in this
spreadsheet, its x and y locations, and the padstack used for each pin. Notice that pin 1 uses the square
padstack, while the others use the round one.

Now let"s create a new footprint from scratch for your design. We will make the footprint for the

pushbutton (Panasonic part EVQ-PAG04M). The mechanical diagram from the datasheet gives us all
the information we need to know.
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4.5

[16.0+0.3 L+0.2
34 |35+05 0.7 CE
B Q.5 max. ! +J%\ 401,081

A 1y
616 s |
(] o
C-)\ § ) = Recommended PWB piercing plan
kj - (Pitch tolerance: +0.1)
i ]}_% - = i = View from mounting side

Create New Fookprinkt

I ame af Footprint [=]

Units

& English

" Metic

0K I Help | Cancel |

Name the footprint PB, and keep English for the Units. Even though the dimensions for the part are
given in metric, most PCB fabrication measurements are still done in inches (or mils, 1/1000 of an
inch). We can switch between the two systems fairly easily in OrCAD. Click OK to create the part.
You will now see a new part with just one pin in the Library Manager.

Since this is a metric part, we need to change the systems settings to use metric instead of English.
Select Options>System Settings to bring up the following dialog. Change the systems settings as
shown.

System Settings x|
~Display Units ——————— ~Grids
" Mils [m] - . .
= Yisible grid : I
¢ Inches [in] A !
" Microns [u) Detail grid [X,Y]: |_1

& Millimeters [mm)]

~ Centimeters [cm)] Place grid PXY]: |_1
Display Resolution: Routing grid: |17

II].I]254 Via grid: liﬂ
Ot
’]gcrement: |g|] Snap: ||] 1!

Workspace Settings... |

0] 4 I Help | Cancel |
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Click ok when you have made the changes. Now you are working in a metric system. The switch has 4
pins total, but we only need to define one padstack since the pins are all the same physically (not
electrically). Open the padstacks spreadsheet. We will edit the padstack T1, which is already being
used by pinl. First, let"s start from scratch and fill in information for only the layers that we care about.
In the spreadsheet, double-click the padstack name T1. This brings up the Edit Padstack dialog for all
layers in the padstack.

Edit Padstack x|

Padstack IpB

17 Padstack Layers

[~ Non-Plated

[~ Use For Test Point
[” Large Thermal Relief
[~ Flood Planes{Pours

Pad Shape

" Bound ' Oblong

" Bquare " Rectangle

! Oval € Thermal Relief
. Annular & Undefined

[¥ Mo Connection

Pad Rotation: I
I Pad Height: I
X Offset: I I

oK I Help | Qancell

Pad Width:

¥ Offset:

First, change the name of the padstack to something more useful like PB (the name of our footprint).
Doing this will make this padstack easier to find in Layout when there are 100s of padstacks to choose
from. Next, select the Undefined radio button. This will reset the padstack definitions on every layer.
Click ok to continue. In the spreadsheet you should now see a padstack called PB with no layers
defined.

=10l x|
Padstack or Pad Pad Pad X
Layer Name Shape Width Height Offset C
PB
TOP [ Undefined ]| 0.00 [ 0.00 [ 0.00 |
BOTTOM Undefined 0.00 0.00 0.00
PLANE Undefined 0.00 0.00 0.00
INNER Undefined 0.00 0.00 0.00
SMTOP Undefined 0.00 0.00 0.00
SMBOT Undefined 0.00 0.00 0.00
SPTOP Undefined 0.00 0.00 0.00
SPBOT Undefined 0.00 0.00 0.00
SSTOP Undefined 0.00 0.00 0.00
SSBOT Undefined 0.00 0.00 0.00
ASYTOP Undefined 0.00 0.00 0.00
ASYBOT Undefined 0.00 0.00 0.00
DRLDWG Undefined 0.00 0.00 0.00
DRILL Undefined 0.00 0.00 0.00
COMMENT LAYER Undefined 0.00 0.00 0.00
SPAREZ Undefined 0.00 0.00 0.00
SPARE3 Undefined 0.00 0.00 0.00
T2
1 I Bz
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We will now set each layer individually. You can also select multiple layers at a time by holding down
the CTRL key when you click the layer name. Firgt, let"s define the size of the drill used for this part.
The datasheet tells us that we need a drill of 1 mm for this part. Select the layers DRLDWG and DRILL.
When you have multiple layers selected, you will need to right-click and choose Properties to bring up
the Edit Padstack dialog. Choose the Round radio button and give the width and height a value of 1.
Click ok when done. The changes you made should now be reflected in the spreadsheet.

Now we will define the amount of metal on the routing layers beyond the size of the drill. This is
called the annular ring. Each board shop will have requirements on the minimum annular ring size
based on the drill diameter. In most cases 20 mils (1 mil = 1/1000 inch) is a safe bet. 1 mm is
approximately 40 mils, so 20 mils is about 0.5 mm. Select the following layers and bring up the Edit
Padstack dialog: TOP, BOTTOM, INNER. Even though we have no inner routing layers, it is good
practice to go ahead and define them. Make the pads round and put the value of 1.5 in the height and
width fields.

Next, we need to define the clearance on the plane layers. The middle layers of our circuit board are
solid pieces of copper that are used for power and ground. To prevent short circuits, we need to define
a clearance around our drill. Most board houses will also have requirements for this, but 35 mils
beyond the drill size is usually a good start. In our case, we will do a little rounding and just use 2 mm.
Select the PLANE layer and define a round pad with a height and width of 2 mm.

The last thing we need to define is the solder mask. This is usually defined as slightly larger (about 5
mils) that then annular rings on the top and bottom layers. Select SMTOP and SMBOT and make them
round pads with height and width of 1.625 mm.

You have finished defining your padstack for this part. You can close the spreadsheet and you will see
that pin 1 should now look a little different based on the changes you just made.

Y ou probably noticed that you don“t need to define all of the layers. Asaguide, here are the layers that
you need to define for thru-hole and surface mount parts.

= Thru-Hole —TOP, BOTTOM, INNER, PLANE, SMTOP, SMBOT, DRLDWG, DRILL
= Surface Mount — TOP, SMTOP, SPTOP

As far as padstacks are concerned, surface mount parts are a lot easier to work with.

Library Manager can be a bit flaky sometimes, so it is best to save your changes to footprints often. Go
ahead and click save As. You have not yet created a footprint library, so you will need to click the
Create New Library button. Browse to your 1ib directory and name the library Elec424Tutorial.

Let"s now clean up a few things before adding the rest of the pins. You will see alot of text on your
screen. Most of it is on the layer ASSYTOP, which we will not use. This text is safe to delete. Open the
text spreadsheet and you will see five text items. Select all the text on the ASSYTOP layer and delete
them. This will clean up your footprint a bit. You can leave the reference designator text on the SSTOP
layer. We will need it.
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We can add pins to the footprint in a number of ways, but the easiest way to do this is to use the
footprints spreadsheet. Open the spreadsheet and you will see just pin 1 with an x,y location of 0,0.
ALWAYS PLACE PIN 1 AT 0,0. For this part we have to take note of a few things. Our schematic
symbol has pins 1 to 4, while the datasheet for the part labels the pins A, A', B and B'. We will make
pin 1 = A’ pin 2 = A, pin 3 =B and pin 4 = B'. To create a new pin, just highlight pin 1 in the
spreadsheet and type CTRL-C. This will create open the following Add Pad dialog.

x|
Adding new pad
to footprint PB2
Pad Name: |2
PadX [0 ¥ 65
Padstack Name
FE [Local] j
Pad EntryfExit Rule Additional Rules
' Standard [~ Allow via under pad
 Any Direction [” Preferred Thermal Relief
" Long End Only [” Forced Thermal Relief
elp_| Cancel |

This dialog allows you to give the pad a name (OrCAD autoincrements, so 2 is already given as the
name), adjust the x and y coordinates of the pin, and choose which padstack you want to use for the
pin. In most cases, you will leave the other settings as they are by default. Set the x and y coordinates
as they are shown above and click oK. Add the remaining two pads as shown on the mechanical
drawing for the pushbutton. When you close the footprint spreadsheet, your footprint should look like

this.
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_ILibrary - Pin Tool (DRC OFF) =0l x|
o

You are not quite done with the footprint even though all the pins are placed. There are just a few
things left to do. First, we need to define a place outline. A place outline is a mechanical boundary that
Layout uses to keep parts from hitting each other once assembled. In this case, the part outline is easy
E to draw. The physical switch does not extend beyond the square defined by the pads, so we will

just draw a box around them. To do this we use the Obstacle Tool. Click the tool icon to switch
to the obstacle tool and then right-click in the workspace. Select New from the context menu. Right-
click again and select Properties. The following dialog box will appear.

Obstacle Name  |p| ACE_OUTLINE

Obstacle Type
|Pla|:e outline ﬂ

Height
0.254

Obstacle Layer
|Gl|:|bal Layer ﬂ

Copper Pour Rules

- -

Mote: Use Pin Tool command 'Toggle Copper Pour Seed'
to set copper pour seedpoints
r r

| Pin Attachment.. |

0K Help Cancel
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Give the obstacle a meaningful name. Select Place Outline as the Obstacle Type. The width in this case
is arbitrary. The layer is very important. This part is a thru-hole part, so in this case we want to make
sure that surface mount parts on the bottom side of the board will not interfere with this part. By
choosing Global Layer, the place outline will extend through every layer of the board. If this were a
surface mount part, we could put the place outline on the top layer only. Click OK when you are done
making changes. Now you need to draw the outline. Left-click to place each corner. When you have
drawn at least 3 corners, you can press ,F* to have OrCAD finish the outline for you. It should look
like this.

L Library - Obstacle Tool {DRC DFF}

There is just one last thing you need to do to make your footprint complete. It is often nice to have an
outline of the part on the silkscreen layer. This is not necessary, but it is a nice touch and makes things
a bit easier during assembly of your board. We can easily make this outline by copying the place
outline in the obstacles spreadsheet. Open the obstacle spreadsheet and copy the place outline by
highlighting it and pressing CTRL-C just like you did for copying a pin. Double-click the new obstacle
to bring up the Edit Obstacle dialog. Give the obstacle a meaningful new name, change the type to
Detail, and change the layer to SSTOP.

Congratulations! You have created your first footprint.

| have provided a library of the remaining footprints for use in this design. Use the Add... button to add
the library to the list of available libraries. Use the Save As button to copy each footprint into your own
library. You can find this library on Owlnet at:

/[ horre/ j pfrantz/ el ec424/tutorial/lib/tutorial.llb

Copy all of the parts from this library into your library.
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7.4 ASSIGNING FOOTPRINTS TO PARTS — You will now switch back briefly to working in Capture. Open
your tutorial schematics if they are not already open. You have defined a set of footprints to be used in
your design, but now you must assign those footprints to each of the parts in your design. Each part in
your schematics has a property called PCB Footprint and this must match one of the footprints in your
footprint library. There are several ways to assign footprints to schematic symbols. One way is to open
the Property Editor by double-clicking the part in schematics. This will show you all the properties for
that part. Double click the pushbutton switch on the first page of your schematics. This is the part
whose footprint you just drew.

% Property Editor : o ] |
Mew Column... I Apply | Dizplay...| D[elete Property | Filker by: IDrcad-Layout j Help |
Value Reference| Primitive | Hame|Power Pins Visible| PCB Footprint| COMPFIXED| C + |
1 Elec424Tutorial : Page 1 - Power & Connectors : SWH (PUSHBUTTORN S DEFALLT | /00547 r FB

A *]\Parts £ Schematic Mets A Pins A Title Blocks A Globals A Ports A Alias| 4] | o[

There are quite a few properties, and it may seem a bit confusing. Using the drop-down list, you can
filter by specific properties. Choosing Orcad-Layout will help make things make a little more sense.
You should be able to see the PCB Footprint property now and assign it a value of PB, the name of the
footprint you just drew.

Now imagine that you have hundreds of parts in your design. It could take quite a while to assign each
footprint to every part. It would be much better if we could do it en masse. Fortunately, there are
several methods we can use to do this. Close the property editor and press CTRL-A while on a page of
schematics. This will highlight every part on the page. Press CTRL-E to bring up the Property Editor.
Now you can see the properties for every part you have highlighted (make sure you are on the Parts tab
of the spreadsheet because others are also visible). Now you can assign footprints to an entire page at
once.
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8 Property Editor =laxl
MNew Coluri... I Apply | Display...l Delete Property | Filker bu: IDrcad-Layout j Help |
Value |Reference| Primitive |MHame|Power Pins Visible|PCE Footprint| COMPFIXED| CON + |
1 Elec424Tutorial : Page 1 - Power & Connectors : Y1 OSC 1hHz 1 DEFALLT :Ha062 I QO5C
2 Elec424Tutorial : Page 1 - Power & Connectors : U2 TIL311 uz2 DEFALLT iz I DIP-14
5 Elec424Tutorial : Page 1 - Power & Connectors : M1 MAXEDS/4 1)) DEFALLT /505 - DIP-g
4 Elec424Tutorial : Page 1 - Power & Connectors : SW1 PUSHEUTT S DEFALLT G idad? - [3=)
5 Elec424Tutorial : Page 1 - Power & Connectors : R2 150 R2 DEFALLT /355 - RES-AXIAL
B Elec424Tutorial : Page 1 - Power & Connectors : R1 1K R DEFALLT iiass - RES-AXIAL
7 Elecd424Tutorial : Page 1 - Power & Connectors : 1M PJ-0024, J1 DEFALILT iod30d I PJ-0024
8 Elec424Tutorial : Page 1 - Power & Connectors : D1 BLUE 3] DEFALLT /00377 r LED
9 Elec424Tutorial : Page 1 - Power & Connectors : C6 0AuF CE DEFALLT Gii223 I CAPMP
10 Elec424Tutorial : Page 1 - Power & Connectors : C5 0AuF c5 DEFALULT :iadiad I CAP-MP
1 Elec424Tutorial : Page 1 - Power & Connectors : C4 0AuF c4 DEFALLT 0835 I CAP-MP
12 Elec424Tutorial : Page 1 - Power & Connectors : C3 1 0uF <3 DEFALILT e I CAP-POL10O
i Elec424Tutorial : Page 1 - Power & Connectors : C2 1 0uF c2 DEFALLT idsas - CAP-POL10O
14 Elec424Tutorial : Page 1 - Power & Connectors : C1 1 00uF ] DEFALLT o7 I CE_RAD
=
A *]\Parts £ Schematichiets A Pins A Tile Blocks A Glokals A Ports A Alias] 4 | | LI—/A

This is certainly an improvement. Now you can manipulate all the parts on one page. But what if you
had 10 or more pages of schematics? This could still be cumbersome. In the next section, | will
describe a much more powerful way of editing the properties in your design.

7.5 IMPORTING AND EXPORTING PROPERTIES TO AND FROM SCHEMATICS — As you may have noticed
by now, OrCAD stores quite of number of properties in the design file. However, it can sometimes be
cumbersome to manipulate these in OrCAD itself. Luckily, it is possible to export the properties of
your entire design so that they can be edited in another program like Microsoft Excel. We will use this
feature to assign footprints and other part information. After reading this section you may think that
this is a lot of trouble to go through for this small amount of work. For this design, that may be the
case. However, in much larger designs this is truly a timesaver.

To export properties highlight the top-level design file in the file view of the project explorer (the one
with the dsn extension). Then select Tools>Export Properties... You will see the following dialog.

X

[ &
_ Corcel |
_ teb |

Export Properties

—Scope K

& Export entire design or Librany

" Expart selection Cancel

Help

 Conterts
%' Part Properties
" Part and Pin Properties
£~ Flat Net Properties

Maode
%' Export Instance Properties

" Export Decunence Properties

Expart File:
IC:\DDEUMENTS AMD SETTIMNGS W ADMIMIS i Browse.

You can leave all the default selections. Just click OK to create the export file. It will be placed in the
same directory as your schematic project and should have an exp extension. We can now edit this file
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directly and re-import it into Capture. If you look at the file in a text editor like Notepad, you will see
that it is just a tab-delimited file with the values enclosed in quotation marks. Let"s open this file with
Microsoft Excel so we can manipulate it better.

Start Excel and select File>Open... Browse to where your file is located. You will probably have to
change the file type to All Types (*.*) to see the file. Selecting the file will start the Text Import Wizard.

Text Import Wizard - Step Z of 3

This screen leks vou set the delimiters wour data contains, ¥ou can see

hows wour text is

affected in the preview below,

elimiters
v Tab
[ space

[~ Semicolon [~ Comma
[~ Gther: I_

21|

[~ Treat consecutive delimiters as one

|

Text gualifier:

rData preview

"DESIGH"
"HEADER"

"PAPTINST: Elecdid4Tutorial:Page € - Hilinx PLD:Z043"
"PARTINST: Elec4f4Tutorial:Page £ - Hilinx PLD:1641"
"PARTINST: Elec4Z4Tutorial: Page 2 - Hilinx PLD:Z151"

"
"clo
gz
hcgn

"C: DOCUMENTS ﬂ

] —

vl

Cancel |

< Back | Mext = I

Einish |

Click the Next button on the first screen. On the second screen, it is important to change the text
qualifier to {none}. This will preserve the quotes around the values. If you do not do this, then you will
be unable to re-import the file back into OrCAD. When you have made this change you can go ahead
and click Finish. You will now have the datain Excel. Let"s do a few things to make moving around a
little easier. First, | like to freeze the top two rows so that they are always visible. This way | can
always see what the name of each column is. To do this, click row 3 to highlight the entire row. Then
select Window=>Freeze Panes.

B ELEC424TUTORIAL. EXP =1o)=l
A B C D E F G H 1 R B RS R
| 1 "DESIGN" "CADOCUMENTS AND SETTINGSWADMINISTRATORDESKTOPELECA24TUTORIALS CHIELECAZATUTORIAL DM
2 "HEADER'"ID" "Part Refel"value"  "PCEB Foot"Source P:"Graphic" "Supplier” "SupParh "PetlnitCe"Motes"  "Manufact"ManPatbMum”

"PARTINSC10" "¢10" BV "CAP MP.ICAR NP "=null=" "<null=" "<nullz" “<nollE" C<pullz" 0 "=poll="

| 4 "PARTING"J2" g2 "CONN-2x " "COMZO.MN "CONZ0.MN "<null="  "<null=" “"<noll=" "<noll=" <ol <nollz"

| & "PARTINS"CB" "ca" “0.1uF" "CAP MP.ICAR NP "<nall=" "<null=" "<huoll" MznollEt 0 C<nullEt o enoll="

| 6 "PARTING"CS" "ce” "0 1uF" "CAP MP.ICAP NP "<null=" "<null=" "<noll=" M<nollEt <nullE" <noll="

| 7 "PARTINS"CT" "CT “0.1uF" "CAP MP.IUCAP NP "<null="  "<null=" "<null>" “<noll=" C<null=" <ol

| 8 "PARTINE"J3" "J3" "CONN-2x " "COME.Ma "CONB.Ma "<null="  "<null="  “<noll="  "<noll=" <ol C<nollst

| 9 "PARTINGT"U3" "u3" "KCBE3E-P " "$CO53E-P "HCI536-F "<null="  "<null=" "<hull>" M<noll=" 0 C<nullEt <noll="

| 10 |"PARTINS"C11" "Gt “0.1uF" "CAP MP.IUCAP NP "=null="  "<null=" "<null>" M<nollEt C<nollzt 0 C<=noll="

| 11 |"PARTINS"C12" "c12t "2 2uF" "CAP POL"CAP POL"<null="  "<null="  "<noll=" "<noll=" "<pollz" <nollz"

| 12 |"PARTINS"U1" U1 "MAXBOIZ "DIP-8" "MAMBDZA "MAXEDZ "<null=" M<null>" "<noll=" <ol M<noll=t tenoll="

| 13 |"PARTINS"CE" "CB" "R "CAP-MP" "CAP NPI"CAP MP.I"<null="  "<null>" "<null=" <ol "<noll=" <ol

| 14 |"PARTINS"LZ" 2" “TIL311" "DIP-14" "TIL311.Me"TIL31 1. Ne "Meweark” "08FG724" "17.61" ™ “Texas Ing "TIL311"

| 15 |"PARTINE "Y1" "t "OSC IME"OSC” "OSC Mo "OSC. Moy "<null="  "<null=" <noll=" "<hollE 0 "<nuollEt | C<nollst

| 16 |"PARTING"C3" och “10uF" "CAR-POL"CAP POL"CARP POL"=null="  “"<null>"  “<null=" “<poll=" "<nollz" "<noll="

| 17 |"PARTING"3W1" "SWWT" "PUSHBL"PBE" "PUSHBU"PUSHBU "Digikey" "FPOO0SS" "0.29" "260gf"  "Panasonit"EVQ-PAGO4M"

| 16 |"PARTINS"C1" "1 "100uF"  "CE_RAD""CAP POL"CAP POL"<null>"  “<null=" “<null="  “<null=" "<nollz" "<noll="

| 19 |"PARTING"R2" "R2" "150" "RES-LXIL"R.Mormal "R Narmal "<null="  “<null=" <ol Cspoll=" 0 M<nollz" M<noll="

| 20 "PARTINS"D1" ‘o1 "BLUE" | "LED" "LED.Morr "LED. Morr "<null=" "<null="  "<null=" M<noll=" 0 C<nollE" <noll="

| 21 "PARTINS"R1" "R1" "R "RES-4%I£"R.Mormal' "R .Normal "=null>"  “<null="  “<null=" “<poll=" 0 "<oollz" 0 t<nollEt

| 22 "PARTING "C4" "c4" "OuF" "CAP-MPY "CAP MP.I"CAP NP.I"<null="  "<null="  "<null=" "<noll=" <ol <ol

| 23 "PARTING"C2" "c2" “10uF" "CAR-POL"CAP POL"CARP POL"=null="  “"<null>"  “<null=" “<poll=" "<nollz" "<noll="

| 24 |"PARTINS"CS" "ca" "DAuF" "CAP-MP" "CAP NPI"CAP MP.I'<null="  "<null>" "<nuoll=" <ol U<nollEt <ol

| 25 |"PARTING"J1" "J1" "RU-002A" "PJ-002A" "CONM JA "COMN J& "<null="  "<nullz" "<nullz" “<nollzt 0 anollE" Mol

26

B

25|

129

1[4 [» [»/[" ELEC424TUTORIAL <] =
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Next, | like to sort the spreadsheet so that it makes a little more sense. Highlight all of the rows and
columns of your spreadsheet except the first row. Then select Data->Sort... to bring up the Sort dialog.

I like to sort by Vvalue and then by Part Reference. Once this is done, your parts should all be grouped
by common value. For example, all of your 0.1uF capacitors should be next to each other. This will
make it much easier to assign footprints and other properties to similar parts.

s 2|x|| IMPORTANT NOTE: It is crucial that parts with the same value all have the
Sork by same text in their value fields. For example, you may know that .1uf and
[ame =] Ascendig 0.1uF are the same thing, but OrCAD treats that as two separate values
" Descending and will think that the two are completely different parts. This will

Then by complicate parts ordering and make your BOM (parts list) unreadable. If

Fart Reference” ¥ Ascending you find discrepancies like this, you can fix it in Excel or in OrCAD.
"~ Descending

Then by

[ ] © Assendng Fill in the remaining footprints based on the chart below. The

" Desrending reference designators in your schematics may vary slightly from
IRl those in the table, but this will make no difference to the design. Two
 Headerrow (" Noheadsr raw things are important when you are assigning the footprints. First,
optons.. | [ x| cace || Make sure that you enclose the value in quotation marks or the

import back into OrCAD won"t work. Second, make sure that the
footprint name matches exactly the name that you gave your footprint in your library. If the name does
not match, then you will get errors when you export your design to Layout.

"Part Reference" "Value" "PCB Footprint"
"C10" "0.1uF" "CAP-NP"
"Cc11" "0.1uF" "CAP-NP"
"C4" "0.1uF" "CAP-NP"
"C5" "0.1uF" "CAP-NP"
"C6" "0.1uF" "CAP-NP"
"CT" "0.1uF" "CAP-NP"
"C8" "0.1uF" "CAP-NP"
"co" "0.1uF" "CAP-NP"
"C1" "100uF" "CE_RAD"
"c2" "10uF" "CAP-POL100"
"C3" "10uF" "CAP-POL100"
"R2" "150" "RES-AXIAL"
"R1" "1K" "RES-AXIAL"
"C12" "2.2uF" "CAP-POL100"
"D1" "BLUE" "LED"

"J2" "CONN-2x10" "CONN-2x10"
"J3" "CONN-2x3" "CONN-2x3"
"u1" "MAX603/4" "DIP-8"

"y1" "OSC 1MHz" "OSC"

"J1" "PJ-002A" "PJ-002A"
"SW1" "PUSHBUTTON" "PB"

"u2" "TIL311" "DIP-14"

"u3" "XC9536-PLCC44" "PLCC-44"

Save the file in Excel. You will get several warnings about the incompatibility of the format. You can
just ignore these. There is one small last step that we need to do before we can import back into
OrCAD. Excel will replace one set of double quotes with three, so we need to open the file in a text
editor. Use Notepad or another text editor to open the file and do a search and replace to change "
with ". Save the file when you are done.
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Now you can import the properties file back into OrCAD. In Capture, highlight the design file in the
file view of the project explorer. Select Tools>Import Properties... Browse to your properties file and
click oK. You should not get any errors during the import. If you do, then there is likely a wrong
footprint name or some missing quotation marks in the file. You will need to correct this before
proceeding.

7.6 EMBEDDING THE BOM IN SCHEMATICS — You may have noticed in Excel that some parts had some
extra information. OrCAD is a great place to store information about where parts are bought, who
makes them, how much they cost, etc. If all the information is there, then OrCAD can use the
information to automatically generate the BOM (Bill of Materials). The BOM will help you be
organized when ordering parts, and it is essential for the person assembling your board. There are
several extra fields that you probably saw with this kind of information.

= Description — A description of the part. Usually I cut and paste this from the description of the
part from the supplier‘s web page (e.g. Digi-Key).

= ManPartNum — The manufacturer"s part number.

= Manufacturer — The manufacturer of the part.

= Notes — Any miscellaneous information about the part that you want to record. Maybe it has a
long lead-time and you want to note that.

= PerUnitCost — How much each part costs.

= SupPartNum — The suppliers part number (e.g. Digi-Key, Arrow, Newark, etc.).

= Supplier — The supplier of the part.

Export the properties of your design again and fill in the information for each part. To help you, | have
put an Excel version of the BOM in the following location on OwInet.

/ home/ j pfrant z/ el ec424/tutorial /assy/ BOM xI s

When you have finished editing the properties, save the file and import them into Capture just like you
did for the footprints.

Now you are ready to have OrCAD generate a BOM for you. To do this, highlight the design file in the

file view of the project explorer. Select Tools=>Bill of Materials... t0 bring up the Bill of Materials
dialog.
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Bill of Materials x|
~Scape— | [ Mode
¢ Process entire design ' |se instances [Prefemed)
" Process selection " Use occumences Cancel |
Heb |

~ Line Item Definition

Header:

IItem\tQuantit_l,l\tHefelence\tPart\tD exzcription'tSuppliertSupPartMu
Combined property string:
I{Item}\t{ﬂuantily}\t{ﬂ eferencel vy alue D escription P HS upplient

™ Place each part entry on a separate fine

r~ Include File
[ Merge an includs file with repart

Combined property stibg:
I{Item}\t{ﬂuantity}\t{ﬂ eferencels iy aluet

| melude file:
|C:'\DDCLIMENTS AND SETTINGSSADMINIST Browse... |
—Report

FeportFile: T Wiew Output

CADOCUMERNTS AND SETTINGSAADMIMNISTR Browse... |

You will want to change a few of the default settings. Cut and paste the following text into the Header
and Combined Property String fields of the dialog box.

Ttem\tQuantity\tReference\tPart\tDescription\tSupplier\tSupPartNum\t
Manufacturer\tManPartNum\tUnitCost\tNotes

{Item}\t{Quantity}\t{Reference}\t{Value}\t{Description}\t{Supplier}\
t{SupPartNum} \t {Manufacturer}\t{ManPartNum}\t{PerUnitCost}\t{Notes}

Then click OK to generate the file. This should put a file called Elec424Tutorial.bom in your sch
directory. This will be a tab-delimited file just like when you exported the design properties. You can
use Excel or another program to make it look a little more readable. Do this and put the finished
version into the assy directory. This is one of the files that you will give to the assembler when you
are ready to have your boards assembled.

7.7 CREATING A BOARD TEMPLATE FILE — You are almost ready to export your schematic design to
Layout. Before doing this, we must create a board template file. This file defines some default
properties for the board that will be used throughout layout. To create a template, start Layout and
select File>New. When you see the dialog, press Cancel. You should now see a blank workspace. You
can use the same shortcut keys that you used in Capture to zoom and center the design (,I*, ,0", and
.C").
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The first thing we need to do is draw a board outline to define the perimeter of the board. For this PCB,
we will make the board 3 inches by 2 inches. The board outline is an obstacle like the ones you placed
in the footprint editor. To create the board outline, select the Obstacle Tool, right-click and choose
New... and then right-click again and select Properties... Name the obstacle BOARD_OUTLINE, its type
should be Board Outline, its Width should be 50 (mils) and it should be placed on the Global Layer.
Place the first corner of the board at 0,0 and then draw from there. While drawing, you can use the
information in the status bar to tell you where in the workspace you are. When finished, your board
outline should look like this.

Next, you will edit the layer stackup. Layout has spreadsheets just like the Library Manager does. Click
the View Spreadsheet icon and select Layers. This spreadsheet defines all the layers that your board
uses and their respective functions in the design. You will see a spreadsheet that looks something like
this.
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=13 x|
Layer Layer Layer Layer Mirror
Name Hotkey NickName Type Layer
TOP 1 TOP Houting BOTTOM
BOTTOM 2 BOT Houting TOP
GND 3 GND Plane [None)
POWER 4 PR Plane [Mone]
INNER1 5 1N1 Routing [Mone]
INNER.2 6 IN2 Routing [None)
INNER.3 7 IN3 Unused [None]
INNERA [i] 1N4 Unused [Mone] |
INNERS 9 INS Unused [None)
INNERG Ctrl + 0 ING Unused [Noneg)
INNERY Ctrl +1 IN7 Unused [None)
INNERS Ctrl + 2 IN8 Unused [None]
INNERSI Ctrl + 3 IN9 Unused [None)
INNER1D Ctrl + 4 110 Unused [None)
INNER11 Ctrl + 5 111 Unused [None)
INNER12 Ctrl + 6 112 Unused [None)
SMTOP Ctrl + 7 SMT Doc SMBOT
SMBOT Cirl + 8 SMB Doc SMTOP =]

You are making a 4-layer board, so we will turn off some of the pre-defined layers because we will not
use them. Double-click the INNERL1 layer to bring up the Edit Layer dialog.

Layer Name

pNNER1

Layer NickName IIN1

Layer LibName

pNNER

Layer Type
~ Routing Layer
& Unused Routing
 Drill Layer

= Plane Layer
" Documentation

¢ Jumper Layer

Mirror Layer

Layer Name

Jumper Attributes... I

[ ok |

Help | Cancel I

Select the Radio button for Unused Routing. Click OK to continue. Do the same thing for the following
layers: INNER2, SPTOP, SPBOT, SSBOT, FABDWG, NOTES. Remember that you can use the CTRL key
to select multiple layers at one time. Also remember that all designs are different and may need extra
layers. For example, a design with surface mount components will need the SPTOP and SPBOT layers.
If we were to place components on the bottom side of the board, then we would likely need a
silkscreen on the bottom and, therefore, the SSBOT layer. Close the spreadsheet when you have made

the changes.
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The next thing we need to do is change the output settings for the Gerber files®. Select Options>Post
Process Settings... to bring up the Post Process Spreadsheet. Select the *. ASB and *.FAB layers. Right-
click and select Properties to bring up the Post Process Settings dialog. Uncheck the box that is
labeled Enable for Post Processing.

Post Process Settings 1[
~ Qutput — Output Settings
—Format
Plot Title: I
" Gerber RS-274D
" Extended Gerber % Shift
C DXF i [
" Print Manager v Shift: li
I=| Print{Plot to File
I”| Force Black & White [7 Center on Page
7 Mirror
~Opti
¥ Keep Drill Holes Open Scale Ratio: I_ To: I_
¥ Create Drill Files Rotation(CC
¥ Owerwrite Existing Files = (ccw
I~ Enable for Post Pmcessing§ 0 90 < 180 ¢ 270
File Name: I
belp_| ance |

Now select all the layers. You can do this by clicking in the cell in the top-left corner of the
spreadsheet (Plot Output File Name). Right-click and select Properties to bring up the Post Process
Settings dialog. Select the radio button for Extended Gerber. This is the format we want to use for
fabrication. Close the spreadsheet when you are done.

Next, you will define a default via® size. Click the View Spreadsheet icon and select Padstacks. This
will open the padstacks spreadsheet and shows every padstack that is used in your design. Since there
are no parts in the design right now, there are not that many padstacks, but this will change after we
import from Capture.

You will edit the VIA1 padstack that is first on the list. This will become the default via for your design.
Editing padstacks here is identical to how you edited padstacks when creating a footprint. Let's start
with a clean padstack. Click the name VIA1 to highlight the entire padstack. Right-click and select
Properties t0 show the Edit Padstack dialog. Select the radio button labeled Undefined and also check
the box labeled Flood Planes/Pours. Click OK when done. This will reset the definitions for all layers
of VIA1. Now you will set the finished drill size. Highlight the DRILL and DRLDWG layers and open the
Edit Padstack dialog. Select a pad shape of Round and give it a width and height of 13.5 (mils). We are
using the same clearance requirements that we used before when defining footprints: +20 mils annular
ring, +25 mils solder mask, and +35 mils plane clearance. Select the TOP, BOTTOM and INNER layers
(we have no inner layers in this design, but it is good practice to define this since we may want to add
layers later in a design). Make these layers round with a diameter of 35 mils. Select the GND and

* Gerber files are in a special format that the board house can read. These are the files used to generate film and fabricate
your board. There is one file per layer of your design.
> Vias are used to connect traces between layers and to make connections to solid ground or power planes.

Revision 1.0 — Spring 2002 30



Rickey's World
www.rickeyworld.info

An OrCAD Tutorial — Page 31 of 55

POWER layers and make these round with a diameter of 50. Finally, highlight the SMTOP and SMBOT
layers and make these round with a diameter of 40.

We will only use one via type in our design, but OrCAD will allow you to define up to 16 different
vias. You might want more than one if you wanted slightly larger vias for carrying high-currents. You
can even assign specific vias to specific nets, but that is beyond the scope of this tutorial.

When a netlist from Capture is imported, we can set the default widths and other properties for all nets
that get imported. After importing we can customize these parameters on a per-net basis. Let"s set the
values for the default net. Click the View Spreadsheet icon and choose Nets. You will see a spreadsheet
with just one net, DEFAULT. After you import your netlist from Capture, you will see all the nets in
your design in this spreadsheet. Double-click the net to bring up the Edit Net dialog.

NetName  [DEFAULT

Net Attribut

v Routing Enabled v Share Enabled [ Highlight
¥ Retry Enabled ¥ Shove Enabled [~ Test Point

Weight [ il 3| 50
Group II] low med high I

Min Width |1|] Conn Width |1|] Max Width |5|]

Net Layers... | Net Reconn... |
Width By Layer... | Net Spacing... |
Help | Cancel |
Edit Spacing x|| Our design will not be too aggressive, so we will use 10 mil

29 Laye,' traces. Set the Min width and Conn Width to 10, and set the

S Imi Max Width to 50. Click OK when you have made the changes.
Track to Via Spacing oo The final thing we need to do to our template is set a few
global spacing constraints. These spacing values will be used
Track to Pad Spacing |1u when you have Layout automatically check for design errors.
: ; ) Select Options>Global Spacing... to bring up the Route
¥ia to Via Spacing 1o Spacing spreadsheet. Click on Layer Name to highlight every
Via to Pad Spacing o cell, and then right-click and select Properties to bring up the
Edit Spacing dialog. Put a value of 10 in every field and click

Pad to Pad Spacing |1u OK. Close the Route Spacing spreadsheet.

oK | Hep | cancel | | Save your template. You are done with it and are ready to

export your design from Capture to Layout.

7.8 CREATING THE NETLIST — To export your design to Layout, you must first create a netlist. A netlist
is a file that has all the parts, footprints and nets for your design in a format that can be read by the
layout program. To start netlist generation, highlight your dsn file and select Tools->Create Netlist...
to bring up the Create Netlist dialog box.
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I{F'CB Faatprint

— Dptions
[~ Bun ECO ta Layout

' Iser Properties are in inches
™ User Properties are in milimeters

Metlizt File:

IE:'\DDCLIMENTS AND SETTINGS\ADMINISTRATORMDESKTOPAELECS24 Browsze... |

(1] I Cancel | Help |

Click on the Layout tab in the dialog box. You don"t need to modify any settings, just click OK to
generate the netlist. When finished you should have a file called Elec424Tutorial.mnl in your sch
directory. Your design is finally ready for import into layout.

8. Starting Layout

x|

~ Libraries

BLUEGPS
BCONT00T
BCON156T
BGA

Add...

Remove I

-~ Footprints

CAP-NP
CAP-POL100
CE_RAD
CONN-2X10
CONN-2X3
DIP-14

DIP-8
MTHOLE125
0SC

PB

PJ-002A
PLCC-44
RES-AXIAL

| Create New Footprint... I

| Save

Sawve As___ I

| Delete Footprint I

8.1 CREATING A NEW BOARD — You have everything that you need to
import your design into Layout. We need to do one thing before we
begin. Layout will try to match the names of the footprints in your netlist
with those stored in the Library Manager. Your library must be at the top
of the list in Library Manager or the import will not work. Open Library
Manager and make sure that your library appears at the top of the list like
in the figure below.

Now start Layout and select File>New. You will first be prompted for
the template file you created. It should be located in your board
directory. Second, you will be asked for your netlist. This should be
located in your sch directory. Third, you will be asked to give your
board file a name. Name this file Elec424Tutorial and place it in the
board directory.

If all the footprint names in your design match those in your library, then
you should get no errors and you will see a screen in layout like the one
below.

If you got one or more errors, then it probably means that you have a

misspelled footprint name. Sometimes, you can also accidentally assign
afootprint that doesn“t have the same number of pins as your schematic
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symbol. If your import is unable to complete, then you will have to find the problem and start the
process again.

One useful tool for finding an error is the 1is file. When Layout performed the import, it generated a
file called Elec424Tutorial.lis in your board directory. Open this file in a text editor like Notepad to see
what it looks like. This file will tell you everything that occurred during the import: what footprints
were added or deleted, what components were added or deleted, and what nets were added or deleted
(you will see later how footprints, components and nets get deleted). If an error occurred, you will see
it here, probably towards the end of the file.

8.2 GETTING AROUND & PLACING PARTS — All of your parts from schematics should be line up on the
left side of the board. Before we start placing them, let"s do afew things to make our job alittle easier.
iR First, turn off DRC (Design Rule Checking). We will use it later when routing, but not now.
== \When you do this, the box with the dashed line border will disappear. Second, I like to turn off a
few layers at this point, just to make the screen a little easier to look at. You will notice a drop

down box with the TOP layer listed. This box lets you select the active layer®.

QI QIEIT2g) wadsl 2]
B

|
While a layer is active, you can press the .-, key to make it visible or invisible. Try it now for the top

layer. Your screen should look a little different, and the coloring in the drop down box will change to
indicate that the layer is now invisible.

® Layout has many shortcut keys to help you move around the program. They are extremely useful, and | encourage you to
be familiar with them. For a complete description, search the help file for keyboard shortcuts.
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® QIITI ) i) 2

_||1 TOF | vi

Make the top layer visible again. You will want to see that one while placing parts and routing. For
now, select the following layers and make them invisible: SMTOP, SMBOT, AST, ASB, DRD, DRL. You
will also notice that there are a bunch of lines connecting your parts. These are connections that are
still unrouted, and this is usually referred to as the ratsnest. When placing parts, it is sometimes useful
to turn this off. So click the Vview Spreadsheet icon and select Nets. Remember when you used this
spreadsheet before? It had just one net called DEFAULT. Now, every net in your design should appear
in this spreadsheet. This spreadsheet can be a useful way to see if you have misnamed nets in your
schematics. Highlight every net by clicking the cell labeled Net Name. Right-click and choose
Properties. Uncheck the Routing Enabled box and click OK. The ratsnest should have disappeared.

i en You are now ready to place parts on your design. To get into parts placement mode,
glf“ﬁ@l; make sure that the Component Tool is selected. In addition to placing the components
an Im== that are in your schematics, you can also place non-electrical components right in
Layout. You will do that now to place some mounting holes on your board. While using the

Component Tool, right-click and select New to bring up the Add Component dialog box.
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Add Component . x|
Beference Designator IMT1
Part Type Il]
Value II]

Footprint... | [BUMPER

Location

[z |u. ¥ |3zuu. Rotation |u
Group # ||] Cluster ID I

Component flags
™ Fixed ™ Locked [~ Key
[~ Mon-Electric ¥ Route Enabled [~ Do Mot Rename

Help | Cancel |

Give this component a reference designator of MT1. Then click the Footprint button and select the
BUMPER footprint from your library. Click OK when finished. The part will now be attached to your
cursor and you can place it on the board. We actually want to place this mounting hole so that the large
pad is on the bottom of the board. Press 7" to flip the part to the other side of the board, and then place
at the edge of the board in the lower left corner.

We want to place a mounting hole in each corner of the board. You could go through the procedure
that you just did to place this component, but there is an easier way that will also allow you to
precisely place components. Click the View Spreadsheet icon and choose Components to open the
components spreadsheet. Scroll down until you see the component you just placed, MT1. Like in other
spreadsheets, you can press CTRL-C to make a copy of the component. Do this 3 times to make
components MT2 to MT4. When you copy the component, it will be placed at 0,0, all three need to be
moved. Double-click MT2 to bring up the Edit Component dialog box.
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Edit Component x|

Beference Designator |MT2

Part Type ||]

Value ||]

Footprint... |BUMPER

Location

X [2800 Y [200 Rotation [

Group # 0 Cluster ID B

Component flags

[~ Fixed ™ Locked [ Key
[~ Mon-Electric + Route Enabled [ Do Not Rename

Help Cancel

Change the coordinates for this part to 2800,200 and click oK. Now do the same for the other two parts
and place them each 200 mils from the corners of the board. Before closing the spreadsheet, highlight
all four parts using the CTRL key. Right-click and select Properties to bring up the Edit Component
dialog again. Since these are non-electric parts, uncheck the box labeled Non-Electric. Also, we don"t
want to accidentally move the part, so check the box labeled Fixed and the box labeled Locked. Finally,
uncheck the box labeled Route Enabled. Click OK to close the dialog and then close the spreadsheet.

Your board should now look like this.

Now you can begin to place the rest of your components. You will probably want to print out your
schematics so that you can see where the components are supposed to go in relation to each other.
When you pick up a component, the ratsnest for that component will appear to show you the
connections to other parts. If you want, you can also turn the ratsnest back on to see all of the
connections. Personally, | like to turn on at least the power and ground nets and give them a distinct
color, especially in designs with multiple voltages. Open the nets spreadsheet and find the net GND.
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Right-click and select Change Color. Choose any color you like. Right-click again and select Enable <-
ﬂ > Disable. When you close the spreadsheet, the GND net should be visible. Do the same thing for

the other power nets. When you close the spreadsheet it will look a little messy. You can use the
Refresh All icon to force OrCAD to redraw connections.

When placing components, you may want to work on a finer grid. Right now, the grid is probably set
at 100 mils. You can change this by selecting Options=>System Settings and then changing the Place
Grid setting. | usually use a value of 25. I also like to adjust the Visible Grid setting to give me an on-
screen reference. | usually use a value of 50 when placing components.

Start placing the remaining components on your board. Start with placing the power connector on the
left side of the board, the PLD in the center, and TIL311 on the right. Try to keep components that
belong together near each other. When you are done, your board should look something like this.

.| 0000O
e @000 0
B - & - I - X :

cooR

XX

The silkscreen is a bit messy, but we will deal with that later. In fact, during routing, the silkscreen can
get in the way, so go ahead and turn off the SST layer now using the same method you used before for
the other layers.

Save your design. We have added a few components, so you may get the following warning.

Layout Engineer’s Edition §§ ﬂ

i Caution: Renamefswap propetties are present on the PCE,
Back annokate ko vour schematic before running AutoECO,
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We will address this later. Do not worry about it now.

IMPORTANT NOTE: OrCAD has a method to allow you to change your schematics while in Layout and to
also make changes in Layout that will get sent back to Capture. Because of this, do not change your
schematics until you are ready to re-export your design to Layout. If you make changes to both the
schematics and the board layout at the same time, you will only make it difficult to reconcile the two.

8.3 ROUTING POWER, GROUND AND COPPER POURS — In any design, it is usually wise to route all
power and ground connections before anything else. On a thru-hole technology board, this is very easy
because connections can be made to the solid plane as the pin passes through the board. The pin will be
“flashed” to power or ground. We need to set up our design so that OrCAD knows that the two planes
are associated with nets. Open the nets spreadsheet and find the net GND. Double-click to open the Edit
Net dialog and click the button labeled Net Layers... Under the section Plane Layers, check the box
labeled GND. This will inform OrCAD that the net GND is associated with the solid plane on layer 2.
Do the same thing for the net vcC5. When you close the spreadsheet, click the Refresh All button. The
ratsnests for vccs and GND will disappear. This is because they are now connected to the plane layer.
To see this, press Backspace to clear the screen, then press 3’ (the shortcut key for the ground layer)
to view the ground layer.

You can now see all of the connections to the ground plane. You can do the same thing for the power
plane. Press,F5" or the Refresh All button to make the whole design visible again.

We still have one voltage net to route, and that is the input voltage from an external power supply. This
net only touches a few components, so we could just put a trace to connect all the components.
However, we can also draw a solid piece of copper and associate it with that net. This is especially
useful for high-current traces or small voltage planes. We do this using the Obstacle Tool just like
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when drawing obstacles for footprints. Turn the Obstacle Tool on and then right-click anywhere in
your design. Select New... and then right-click again and select Properties... to bring up the Edit
Obstacle dialog. Name this obstacle VCC_IN, leave the width at 10 mils. Set the Clearance to 15 mils
Change the Obstacle Type t0 Copper pour. Finally, set the Net Attachment to the name of the net,
which should be v_IN. Click oK and you are ready to draw your copper pour. Draw a rectangle around
the power connector and other components that are attached to this net. When you are done, click
Refresh All to redraw the ratsnests.

Y ou have now routed all the power and ground connections. That was easy, right? Let"s look alittle bit
at some of the tools that OrCAD gives you to check on the progress of your design. Click the View
Spreadsheets icon and choose Statistics. The statistics spreadsheet gives you information on time in
layout, percent of components placed, percent of traces routed, and some other information.

Statistic Enabled Total
Board Area 6.0 6.0
Equivalent IC's 9.1 9.1
Sq. inches per IC 0.66 0.56
# of pins 137 137
Layers 2 28
Design Rule Errors 0 1]
Time Used 710 .10
% Placed 100.00% 100.00%
Placed 27 27
Off board 0 0
Unplaced 0 0
Clustered 0 0
Routed 55 55
% Bouted 100.00% 62.50%
Unrouted 0 33
% Unrouted 0.00% 37.50%
Partials 0 0
% Partials 0.00% 0.00%

100% of your components should be placed, and you can also see that a majority of your traces have
been routed (power and ground make up the majority of connections in most designs). You are well on
your way to completing your design.
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8.4 ROUTING OTHER NETS — You are now prepared to route the other connections on your board. Open
the nets spreadsheet and highlight all the nets in the design. Right-click and select Enable <-> Disable
to make the ratsnets visible for the remaining nets. Refresh the display to clean things up a bit.

Before beginning routing in earnest, it is helpful to change a few settings. Open the System Settings
and make the following changes: Visible Grid = 10, Routing Grid = 5, and Via Grid = 0. Next, select
Options=>User Preferences and check Allow DRC Errors under Global Preferences. You may have to
check the box labeled Activate Online DRC. The box with the dashed line will reappear. While DRC is
on, you will only be able to place routes inside this box, but Layout will inform you if any spacing
errors occur while you are routing. This will help you limit the number of errors that you will have to
clean up later. You can resize the DRC box by pressing ,,B" and drawing a new rectangle.

-:El | =% L et"s route a connection. Turn on the Edit Segment Mode Or Add/Edit Route Mode. The two

have some subtle differences. Experiment with both to see which one you are most
comfortable with. Let"s start by routing the connection for the pushbutton switch. Zoom in a bit and
click on the ratsnest near pin 4 of the switch. Left-click to place a segment of a route. When you get
near to pin 3, you can press ,F* to have Layout finish the trace for you. Pins 3 and 4 should now be
connected. Now connect the resistor and capacitor that are nearby.

When routing you will want to refresh the display occasionally to redraw the ratsnests. Now connect
the resistor to the PLD. Since our traces on the top layer are already oriented horizontally, let's place
this vertical route on the bottom layer. When you begin the route, press 2" to switch to the bottom
layer. Since the resistor is a thru-hole part, there is no need for vias in this situation.

IMPORTANT NOTE: It is a good design practice to keep routes on one layer oriented in the same direction.
For example, you might want to have all traces on the top layer oriented horizontally, while all routes on
the bottom are oriented vertically. Doing this increases the number of vias that are needed, but makes
routing much easier, especially in very dense designs. After routing is complete, you can go back and
remove unnecessary vias. Of course, sometimes it will be impossible to adhere to this guideline.

Route the trace to the top of the PLD. When you get near the top, you can press V" to place avia. Then
you can switch to the top layer to complete the trace.
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You now have your first complete route. You can begin to finish the other connections. Start by
routing one component at a time. For example, you might route the TIL311 next, as is shown above. It
is also important to route critical signals first, such as clocks and resets. Remember that you can zoom
and pan during operations such as routing. The DRC routing box will move with you. With the current
DRC settings, you may sometimes see circles around your traces if you get too close to another net or
pad. If this happens, then Layout is warning you that you are making a spacing violation with your
route. You will need to fix it. I would also suggest that you browse the shortcut keys in the help to see
which shortcuts will be useful during routing. When you are done routing, your design may look
something like this.

e (EREERERGSEN

Congratulations! All the really hard work is done. Now there are just a few remaining steps to
complete your board for submission to a board shop for fabrication.
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8.5 PERFORMING ECOs & BACK ANNOTATION — What if you wanted to make some changes to your
design while you were in Layout? OrCAD provides the means for this through ECOs (Engineering
Change Order) and back annotation. An ECO is used when changes are made in schematics (perhaps
you added some more circuitry or changed some connections). Back annotation is used for changes
made during Layout.

When you saved your file, Layout reminded you to back annotate. This was because we added the
mounting holes to our design, and OrCAD wants to export those back to schematics. Even though it is
not entirely necessary right at this moment, let"s step through the process so you know how it works.
On the menu click Auto>Back Annotate. OrCAD will create a swap file called Elec424Tutorial.swp in
your board directory. It is safe to overwrite your existing board file with the new one. Look at the
swap file in Notepad. You will see several sections. One thing that Layout does is update part and net
properties (such as its coordinates) in Capture. If new components were added, then you would also
see those changes. Now let"s import this file into Capture. Start Capture and highlight your dsn file.
Select Tools>Back Annotate... You can leave the Scope and Mode settings untouched. Use the Browse
button to find your swap file. Click OK to start the update. Occasionally, when you add components
like mounting holes, you will get an error during back annotation. This is usually safe to ignore.

Now let's go the other direction. Perhaps we have one to many decoupling capacitors, so we will
remove one. On page 2 of your schematics, delete on of the decoupling capacitors.

VCC5
L
—— C¢7 —— €8 —— €9 —— cC10l—— c11 |1+ c12
0.1uF 0.1uF 0.1uF 0.1uF 0.1uFI,-fm 2.2uF
e PLD & Connector Decoupling
GND
VCC5
- Ccr —/— ¢ — ¢ —— C1o |+ @&12
0.1uF 0.1uF 0.1uF 0.1uF 7. 2.2uF
e PLD & Connector Decoupling
GND
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Next, save the design and regenerate the netlist as described previously. Close your board in Layout,
but keep Layout running. In Layout select Tools>ECOs->Auto ECO. First, you will be asked for your

original -~ board  file. ~Find the file
Fle Edt Format Help Elec424Tutorial.max in your board directory.

LT OECD R T i i
'FI;LE—A: c? ggCUMENTS AMND SETTINGSMADMIMISTRATORNDESKTORY, Second, you will be asked for the new netlist

FILE-B: C:“DOCUMENTS AND SETTIMGS\ADMINISTRATORMDESKTOPS  file  that you just created. Find the
If "wEoF®" dmmediately follows, no changes were made

Deleting C11.2 from nat GND Elec424Tutorial.mnl file in your sch directory.
beleting C11.1 from net wiCs . . . .

EE;ﬁEmg component C11 Finally, you will be asked for a 1is file to
Mo errors found write to. This file is jUSt a report of the ECO,

and it is safe to overwrite the existing one in
your board directory. When the ECO is done,
you will see the lis file in Notepad with a report of what happened during the ECO. You will also be
prompted to save the new board file. If the report looks OK, then go ahead and overwrite your existing
board file. In our example here, we deleted C11, so the report should look something like the diagram
on the left. If you open the new board file, you will see that capacitor C11 is no longer in the design.

Before ECO After ECO

When you open your board after an ECO, you may get the following message.

Drill Chart Duplicate x|

Warning: At least one drill drawing symbol is used For bwo different drills, Please check Drill Chart Spreadshest,

Just click oK. We will fix this problem a little bit later.
Deleting this part was just a demonstration. We really want that capacitor in our design, so let"s put it

back. Adding new components to a design requires a little more caution than deleting components.
Open up page 2 of your schematics and cut and paste one of the other decoupling capacitors.
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VCC5
R
c7 c8 — ¢9 —— c1o0 | clo_|_|+ €12
0.1uF 0.1uF 0.1uF 0.1uF | 0.1uF | 7 2.2uF
0|
e PLD & Connector Decoupling
GND

When you cut and paste a component, every property gets copied, including the reference designator.
This design now has two capacitors called c10. If you were to try and perform an ECO right now, it
would cause much confusion. Double-click the new capacitor and change the reference to C>.

IMPORTANT NOTE: After Layout has begun, any new parts in schematics should be given a 7" in the
reference designator. Then let Capture's annotation utilities give a new number to the part.

Since we have some new parts, we need to annotate the design again. Perform an incremental reference
update as you did before. The new part should now have a number. Regenerate the netlist and start an
ECO. When done, the part should be back in the design. However, when we cut and paste parts, all
properties are copied, and this includes x and y locations on the board. Our new part is probably sitting
right on top of another part. Use the components spreadsheet to locate the new part. Give it a new and
safe location such as 0,0 and then use the Component Tool to place it in the proper location. You could
also avoid this problem by resetting the coordinate properties in Capture before regenerating the
netlist.

You will often use ECO to do forward-annotation, but there are only a few occasions where you may
want to perform back annotation. One such instance is to rename components. Right now, all the
components in your design are named according to their order in schematics. However, in a larger
board, it will be very hard to tell where a specific component is during debug. The components on the
board will seem to be named in a random manner. Layout can rename your components for you, which
will make finding them on the board much easier. To see the results of this operation, make the
silkscreen layer visible again (SST). Select Options>Components Renaming... and choose Right,
Down... in the Rename Direction dialog.

Rename Direction - ll

¢ Right. Up e
" Left, Up " Left, Down
= Up, Right " Up, Left

" Down, Right " Down, Left

oK I Help | Qancell

Next, choose Auto>Rename Components. You silkscreen should look a lot different now.
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Before Renaming After Renaming

Since you have changed the reference designators in your design, you need to generate a swap file and
perform back annotation. You should do this IMMEDIATELY. If you don", it can cause some
serious problems for you later in the design. When you read the swap file into Capture, you may get

errors on renaming the mounting holes. It is safe to ignore these.

8.6 CHECKING FOR ERRORS — The next step in the design process is to check for any spacing errors.
OrCAD uses the spacing variable that you set earlier to determine if there are errors in your design. We
used 10 mil spacing from all features as a minimum for this design. To perform a Design Rule Check

(DRC) choose Auto>Design Rule Check... from the menu.

Check Design Rules e x|

—Check Rule Settings

Placement Spacing Violations
Route Spacing VYiolations

Net Rule Yiolations

Copper Continuity Violations
¥ia Location Yiolations

Off Grid Yias

Pad Exit Yiolations

SMD Fanout Yiolations

Test Point Yiolations

Check Copper Pour

Select All | Clear All |

¥ Check Detail Obstacles
[” Report DRC/Route Box Violations Only

0K I Help | Cancel |

AAXMAIAACIA

Make sure all the Check Rule Settings are checked and click OK. Your design will rarely contain no
errors, and you will need to look at the errors spreadsheet to see what the errors are. Some can be

safely ignored.

Revision 1.0 — Spring 2002 45



Rickey's World
www.rickeyworld.info

An OrCAD Tutorial — Page 46 of 55

Errl:lr Markers

Location Type
[200,1800] Pad Spacing Error "MT1.1"; Obstacle 18
[2800,1500] Pad Spacing Error ""MT2.1'; Obstacle 18
[200,200] Pad Spacing Error ""MT3.1'; Obstacle 18
[2800,200] Pad Spacing Error "MT4.1"; Obstacle 18

In this example there are four Pad Spacing Errors, one generated by each of the mounting holes. In this
case OrCAD is complaining because the place outline for the part is on the edge of the board. This
error is OK to ignore. If there are errors that need to be fixed, you can delete the marker from the
spreadsheet. Let"s generate a route spacing error so you can see what it looks like. These are the most
important. Move a trace anywhere in your design so that it conflicts with another trace or pad.

Now rerun the DRC. The new errors should appear in the spreadsheet.

Errur Markers
Location Type Comment
[200,1800] Pad Spacing Error "MT1.1"; Obstacle 18
[2800,1800] Pad Spacing Error "MT2.1"; Obstacle 18
[200,200] Pad Spacing Error "MT3.1'; Obstacle 18
[2800,200] Pad Spacing Error "MT4.1'"; Obstacle 18
[2051.1619] Route Spacing Error "'J1.3" to "U2.1" Net "PLDIOT' "'J1.4" to "U2.44" Net "PLDIO 44"
[2038.1606] Route Spacing Error "J1.4" to "U2.44" Net "PLDIO44"; "J1.3" to "U2.1" Net "PLDIOT"

You can remove the errors by moving the trace back to its original position. Once the error has been
corrected, you can delete the marker from the errors spreadsheet. Do not try to use the Auto>Remove
Violations tool. It is tempting, but it will actually rip up offending traces and move parts. You will end
up having to do a lot of cleanup and rerouting after using this tool.
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8.7 CLEANING UP & THE DESIGN — Now it is time to clean up your design. You should think of your
board as a work of art. Other people may look at it, so you want it to look nice. Furthermore, a clean
design will ensure fabrication success. When cleaning the design, the following should be kept in
mind.

A. Route Spacing — You have set a minimum of 10 mils for feature spacing in your design. However,
do not pack traces closely together unless you have to. First, you can push the manufacturing limits to
far and some of your boards may come back bad. Second, routing traces closely together is generally a
bad idea because this can result in undesired mutual inductance between traces.

B. Right Angles in Traces — Don"t use right angles in routing your traces. Miter the corners.

BAD

C. Pad Exits — Trace exits from pads should be clean and not come out of the pad at unusual angles.

BAD

D. Remove Extra Vias — Vias add cost to a board, so it is a good practice to remove any unnecessary
vias from your design.
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E. Drills — Drills require some special attention. First, you need to fix the error you got earlier about the
drills. This error occurs sometimes after you perform an ECO. To see the problem, make the Drill
Drawing (DRD) layer visible. Press Backspace to clear the display and then shift-5 to display just the
DRD layer.

The DRD layer is a documentation layer that contains a chart with all your drill sizes and their locations
on the board. The problem is that two drills are using the same symbol. In this case it is the 14 mil drill
and the 150 mil drill. To fix the problem, click View Spreadsheet and select Drills to view the drills
spreadsheet.

Drill Properties x|
Drill Size Symbol Tolerance MNote
13 17 g
Symbol number or letter 1

29 11

34 12 .

It 13 Drill Tolerance |_

37 14

39 15 Drill Note |_
125 16
150 17 DK Help | Cancel

You can double-click the Drill Size cell to adjust the Drill Properties. | suggest starting with symbol 1
for the 13 mil drill and incrementing from there. When you are done, you should have symbols 1 to 8,
and you will no longer get the error when you open your design.

Revision 1.0 — Spring 2002 48



Rickey's World
www.rickeyworld.info

An OrCAD Tutorial — Page 49 of 55

There is one other thing that needs to be done with regard to drills. Some board shops have limitations
on the sizes of drills. The board shop we are using for this project offers only 16 drill sizes’. They have
programs that will scan your Gerber files and automatically adjust the drill sizes for you, but to avoid
any problems it is wise to give them files with the correct sizes in the first place. This way you can be
sure that your board will be manufactured exactly as you send it. It is also a good practice to
consolidate drills anyway. In this design, we might try to adjust the footprints so that the 34 and 35 mil
drill sizes are the same. The board shop will only have to use one drill bit, and this will save money.

To change the drills, we must edit the padstack in the original footprint. The Drill Drawing layer can
help you find which footprints need to be changed. For example, we can see that the PLD and TIL311
use 34 mil drills. This is not a valid size, but a 35 mil drill is acceptable. Open the Library Manager and
use the padstacks spreadsheet to adjust the drill sizes (DRILL and DRLDWG layers) for these two parts.
The footprints you are adjusting should be DIP-14 and PLCC-44. You may have to adjust several
padstacks in each footprint. In addition, make sure that the clearances we defined earlier for each layer
are still good (they should be). Finally, when making changes to footprints like this it is always good to
check the datasheet to make sure that the part will still fit. You are only making very small changes of
1 or 2 mils, but it is important to check.

Once you have made a change to a footprint, and now you need to update the footprint in Layout.
Open the components spreadsheet and find the PLD. Double-click to bring up the Edit Component
dialog box. Click the Footprint button to show the Select Footprint dialog.

Select Footprint x|

— Libraries

BLUEGPS iy [P
BCOMT00T
BCOMT56T

B

DIF-3
MTHOLE125

1] Help

LCancel

RICELOGO bk

Choose the new footprint from your library (not the local cache) and click oK. Click OK again when
asked for the Replacement Range. Do the same procedure for the TIL-311. When done refresh the
display. Your drill chart should no longer show any 34 mil drills.

" For this design we are using PCBExpress, www.pchexpress.com.

Revision 1.0 — Spring 2002 49



Rickey's World
www.rickeyworld.info

An OrCAD Tutorial — Page 50 of 55

Do the same thing for the parts with 37 mil drills and the 39 mil drills. Adjust the 37 down to 35, and
adjust the 39 up to 40. When you are done, you should have only 6 unique drill sizes.

F. An Orderly Silkscreen — Use the Text Tool to adjust the silkscreen. All text should be oriented in the
same direction for readability. Silkscreen cannot overlap pads or vias (overlapping traces is OK).
Change the Detail Grid to a finer setting if necessary. Reference designators should be placed as close
to the part as possible. Polarity signs should be placed in the correct position.

8.8 DOCUMENTING THE DESIGN — Good documentation of your design will help both in manufacturing
and debug. First, we can add some useful text to the board. For example, the MAX603 part has a
maximum input voltage of 11.5V, so maybe we want to put some text on the board to indicate that.
You can use the Text Tool to create new text. Right-click anywhere in the design and select New... to
get the Text Edit dialog.
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Text Edit x|
Text 219
Type of Text
Text String 11.5Y¥ Max
+ Free " Custom Properties
" Reference Designator " Package Mame
" Component ¥alue " Footprint Name
Text location [135.57,1104.87]
Line Width 8. Text Height 50.
Rotation 270 Char Rot 0
Radius 0. Char Aspect 100
[~ Mirrored
Layer:
|ssTOP |
Comp Attachment.. |
oK Help | Cancel |
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Most text you create will be Free. For good readability, | suggest a Line width of 8 and a Text Height of
75. A 6 mil Line width is about as small as you can go to keep the text readable.

There are a few other things we can place on the silkscreen to document our board. One very useful
thing is to label the pins on the programming header for the PLD. This will make it easier to hook up

the programmer.
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It is also useful to label the 10 header pins with the pin numbers of the PLD that connect to it. You can
also remove the pin numbers of the connector itself to avoid confusion.

J1
23 27 29 34 36 38 40 42 1 Vcc

It is also customary to add a logo and some information about the board, as well as the initials of the
person who designed it. First, let“s add a logo for Rice University. Using the Component Tool, right-
click and select New... Give this new component a reference designator of OWL1. The Footprint should
be RICELOGO from your library. The logo will actually be in the metal layer, so place it somewhere
where it will not interfere with any traces or pads. When placed, open the Edit Component dialog from
the components spreadsheet and check the Fixed, Non-Electric and Locked boxes, uncheck the Route
Enabled box. When you next save your design you will be asked to back annotate since you just added

a new component.

Next, we will add the some information about the board. You will use the Text Tool, but place this
information on the TOP layer instead of silkscreen (SSTOP)
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|~ ] ]
' o000 ¢ ¢ (

Rice University, 2002

Elec 424 Tutorial Board
JPF Rev. x1

We also need to add a few things to the Drill Drawing layer. It is customary to provide board
dimensions and engineering contact information on this layer. Make the Drill Drawing layer visible if it
is not already. First move the drill chart to the right of the board by selecting Tool->Drill Chart->Move
Drill Chart from the menu. Next, add dimension lines using Tool->Dimension->New. Your board should
measure exactly 3000 mils by 2000 mils. Now use the Text Tool to add some text with your name,
phone number and email beneath the drill chart. When you are done everything should look like this.

For the final documentation steps, you will need to turn on some of the other layers. Make sure that all
of the following layers are visible: TOP, BOT, GND, PWR, SMT, SMB, SST, DRD. You are going to add
some text to each layer (outside the boundary of the board) to indicate what layer this is. This is
necessary because you will make a separate Gerber file for each layer and you will need to be able to
tell which layer you are viewing. Using the Text Tool put the following text on each layer above the
board and aligned with the left edge:

= TOP: Layer 1 — Top Routing

= BOT: Layer 4 — Bottom Routing

= GND: Layer 2 — Ground Plane (Negative)

=  PWR: Layer 3 — Power Plane (Negative)

=  SMT: Top Layer Soldermask (Negative)

= SMB: Bottom Layer Soldermask (Negative)
®  SST: Top Layer Silkscreen (Nomenclature)
= DRD: Drill & Fab Drawing
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Finally, we need to add some cut lines to mark the board outline on the TOP and silkscreen (SST)
layers. The board shop will use these cut lines to route out the board from a larger panel. Click View
Spreadsheet and then Obstacles to open the obstacles spreadsheet. Find your board outline. It will be
the only one with the obstacle type of Board outline. Press CTRL-C twice to create two copies of the
board outline. Double-click one to open the Edit Obstacle dialog. Change the Obstacle Type t0 Detail,
Width to 10 and the Obstacle Layer to TOP. Do the same with the other one, but place it on the SSTOP
layer.

18 50 Board outline Global Layer 5 1
19 10 Detail TOP h 1
20 10 Detail S5TOP h 1

Your design is now complete and you are ready to generate Gerber files for fabrication. Before
proceeding, you will want to run the DRC again to check for errors. Once all errors are resolved, you
can proceed to the next step. The Rice logo will generate some errors that can be ignored.

8.9 CREATING GERBER FILES — So, you've finished your design and you are ready to send off the
Gerber files for fabrication. Creating the Gerber files is quite easy. First, select Options>Post Process
Settings... You already set these when you made your board template, but just check to make sure that
the following Plot output File Names are Batch Enabled: *.TOP, *.BOT, *.GND, *PWR, *.SMT, *.SMB,
*SST, and *.DRD. Also verify that each output file's Device is EXTENDED GERBER. If everything looks
OK, then select Auto>Run Post Processor from the menu. You will get a series of dialog boxes, just
click OK, and then you will see a 1is file in Notepad with a report of the processing. At the very
bottom of the file, it should say No warnings or errors. That"s it. Your Gerber files have been made. If
you look in your board directory, you will see the files with the extensions listed above, plus a few
others.

8.10 VIEWING THE GERBER FILES — Before submitting your Gerber files for fabrication, it is best to
look at them in a Gerber viewer. You will often catch mistakes there that you don't see in layout.
OrCAD has a built in Gerber viewer and editor called GerbTool. This is actually a very powerful
program that you can use to edit the Gerber files, but you will just use it to look at them for now. In the
main Layout window select Tools>GerbTool>Open... In your board directory there should be a file
called Elec424Tutorial.gtd. Find this file and open it. You should see your design in GerbTool.
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As noted before, GerbTool can do many different things with your design. However, the only thing
that concerns you here is inspecting your Gerber files. The buttons on the right side of the screen
control which layers are visible. Use them to inspect each layer individually. Once you are satisfied
that each layer looks in order, close GerbTool. You do not need to save any changes when prompted.

9. Archiving Your Design

The final thing you should do is a little file cleanup in your directory hierarchy. OrCAD generates a lot
of files that you don“t really need to keep (they can be generated again, if necessary). Below isalist of
the files you need to keep in each directory. You can safely delete all the others.

= sch\*.opj — Capture project file

= sch\*.dsn — Capture design file

= sch\*.mnl — Layout netlist file

= lib\*.olb — Capture library file

= [ib\*.Ilb — Layout library file

= board\*.max — Layout board file (Y ou don"t need to keep the backup files)
= board\*.bot — Gerber file

= board\*.drd — Gerber file

= board\*.dts — Gerber file

= board\*.gnd — Gerber file

= board\*.gtd — Gerber file

= board\*.pwr — Gerber file

= board\*.smb — Gerber file

= board\*.smt — Gerber file

= board\*.sst — Gerber file

= board\*.top — Gerber file

= board\*.tpl — Layout template file
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